Acuity Scheduling Service Disruption

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted May 19, 2026 - 13:35 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 19, 2026 - 13:06 EDT

Investigating

We are currently experiencing a service disruption where existing users are unable to create new Acuity trials.

Our Engineering team has identified the root cause and is working to implement a solution. All users and services may be affected.

We will provide an update as soon as possible.
Posted May 19, 2026 - 13:06 EDT
This incident affected: Acuity Scheduling.